+ tcsh # tested from u8-ga to: setenv SR u9-ga setenv NBE s10u9 setenv LC_MESSAGES C setenv CD /net/install/pool1/install/`uname -p`/Solaris_10_$SR setenv JUMPDIR /net/install/pool1/install/jumpstart setenv RPOOL `df / | tail -1 | cut -f1 -d/` setenv ERR /var/tmp/err.${NBE}.log setenv OUT /var/tmp/out.${NBE}.log # in case the name service has been switched to another one after installation # relink the proper profile manually. E.g. cd /var/svc/profile ln -fs ns_dns.xml name_service.xml # x86 only: the following call should not result into an error message. # see S10u8 Release Notes for more information /sbin/biosdev cd /var/tmp rm -f $OUT $ERR pkgchk -v SUNWscpr # once for each upgrade to an OS release/update better than the current one pkgrm SUNWluu SUNWlur SUNWlucfg pkgadd -d $CD/Solaris_10/Product SUNWlucfg SUNWlur SUNWluu # check for minimum LU and patch Patches and install all missing ones pca -l | egrep 'patch behavior|Live Upgrade' #pca -i 121430-54 # http://sunsolve.sun.com/search/document.do?assetkey=1-61-206844-1 # sparc S10u6|S10u7 -> u7|u8|u9 #(1st: always, 2nd+: none-global zones, 3rd+: reboot required) checkpatches.sh -p 121430-49 \ 118815-05 120900-04 121133-02 119254-64 119317-01 \ 120235-01 121428-08 121002-03 123121-02 121004-03 119574-02 120996-02 \ 120068-03 119042-10 126538-01 123332-01 119246-27 121901-02 125418-01 \ 123839-07 127922-03 137321-01 138130-01 \ \ 119081-25 124628-05 119252-21 120199-11 124630-13 119578-30 118918-24 \ 119042-10 124327-04 \ \ 118833-36 120272-13 126897-02 122640-05 125369-10 125503-02 126419-01 \ 124204-04 118731-01 122660-10 125547-02 120011-14 #x86 S10u6|S10u7 -> u7|u8 checkpatches.sh -p 121431-50 \ 118816-03 120901-03 121334-04 119255-64 119318-01 \ 117435-02 120236-01 121429-08 121003-03 123122-02 121005-03 119043-10 \ 121902-02 120901-03 120069-03 120070-02 123333-01 126539-01 119247-27 \ 125419-01 118732-01 127923-03 137322-01 138884-01 138131-09 \ \ 121127-02 113000-07 118344-14 \ \ 118844-20 121208-03 118345-12 119082-25 124629-05 119253-22 120200-11 \ 124631-13 121264-01 122035-05 123840-04 \ \ 118855-36 118919-21 119575-02 120273-15 122641-06 125370-05 126420-01 \ 125504-02 124205-05 122661-08 125548-02 126424-03 120012-14 # if a patch from the 3rd+ block is missing, use day-by-day patching procedure # and restart LU procedure after booting the patched BE gpatch -p0 -d / -b -z .orig < /local/misc/etc/lu-`uname -r`.patch gsed -i -e '/^\/var\/mail/ s,^,#,' /etc/lu/synclist lucreate -n $NBE -p $RPOOL -l $ERR -o $OUT lumount -l $ERR -o $OUT $NBE /mnt $CD/Solaris_10/Misc/analyze_patches -N $CD -R /mnt >/mnt/var/tmp/s10$SR-rm.txt luumount -l $ERR -o $OUT $NBE ls -1d /$RPOOL/zones/*-$NBE | xargs -L 1 umount $JUMPDIR/mkProfile.sh -u $CD/Solaris_10 echo 'cluster SUNWC4u1 delete' >> /tmp/profile.orig echo 'cluster SUNWCcvc delete' >> /tmp/profile.orig cp /tmp/profile.orig /var/tmp/profile.$SR echo 'auto_reg=disable' >/tmp/q luupgrade -u -k /tmp/q -n $NBE -l $ERR -o $OUT -s $CD -j /var/tmp/profile.$SR -D ls -1d /$RPOOL/zones/*-$NBE | xargs -L 1 umount luupgrade -u -k /tmp/q -n $NBE -l $ERR -o $OUT -s $CD -j /var/tmp/profile.$SR ls -1d /$RPOOL/zones/*-$NBE | xargs -L 1 umount lumount $NBE /mnt gpatch -p0 -d /mnt -b -z .orig < /local/misc/etc/lu-`uname -r`.patch gpatch -p0 -d /mnt -b -z .orig < ${JUMPDIR}/files/Xsession.patch cd /mnt/var/sadm/system/data/ less upgrade_failed_pkgadds # just in case one wanna overwrite failed pkgs # gsed -re 's,(partial|conflict|action)=ask,\1=nocheck,' \ # /var/sadm/install/admin/default >/tmp/dontask # awk '{ print "pkgadd -n -M -R /mnt -a /tmp/dontask -d $CD/Solaris_10/Product " $1 }' upgrade_failed_pkgadds cleanup4humans.sh /mnt cd /mnt/var/tmp less preserved.txt renamed.txt restored.txt removeSafe.sh \ symlinkchange.txt typechange.txt misc.txt lupatch.sh -d lupatch.sh -r lupatch.sh -i cd / luumount $NBE ls -1 /$RPOOL/zones/*-$NBE | xargs -L 1 umount luactivate -l $ERR -o $OUT $NBE init 6 # NOTE: # # If patches 121431-50/121430-49 (not determined yet, might be even something # > -37) are in use, even the /local/misc/etc/lu-`uname -r`.patch can't # prevent luactivate and bootadm to do really stupid things (i.e. mounting # and unmounting ALL filesystems for each ABE aka alternative boot environment). # So "luactivate" as well as "init 6" aka "shutdown -r" will take about # 1second x NumberOfABEs x NumberOfFilesystem. # E.g. on a system with ~ 2500 ZFSs and 5 ABEs luactivate takes at least # 3 hours and a consecutive "init 6" takes at least 3 hours again - your # services are not available for this time!!! # NOTE2: # Check the content of the /etc/hosts file in each non-global zone. We had # several cases, where luupgrade replaced entries with a wrong IP Address # or a wrong hostame. If the zonename is different than the zone's nodename, # you should also check /etc/nodename, since luupgrade overwrites it # unconditionally as well!